MCOM2 U1 A2 AURT .pdf



Nombre del archivo original: MCOM2_U1_A2_AURT.pdf
Autor: Usuario

Este documento en formato PDF 1.5 fue generado por Microsoft® Office Word 2007, y fue enviado en caja-pdf.es el 19/06/2014 a las 06:19, desde la dirección IP 187.244.x.x. La página de descarga de documentos ha sido vista 1278 veces.
Tamaño del archivo: 130 KB (5 páginas).
Privacidad: archivo público



Vista previa del documento


Actividad 2. Reflexión sobre algoritmos

En asignaturas anteriores hemos visto que al algoritmo se puede representar por
medio de pseudocódigo y diagrama de flujo
Algunos ejemplos que hemos visto son:
1.- Este es un algoritmo visto en la materia Herramientas computacionales para
las matemáticas

El uso que le podemos dar en la vida cotidiana es por ejemplo encontrar la medida
del frente de un terreno de forma cuadrangular que mide x metros cuadrados de
área

2.-Este ejemplo es de la materia de computación I y sirve para encontrar la
solución de una ecuación de segundo grado

Es de gran para representar datos económicos.
La diferencia que encuentro entre los algoritmos vistos y los de la vida cotidiana es
lo estructurados y detallados que son los algoritmos dados ya que en la práctica
común, de hacerlo a mano en muchas ocasiones reducimos la cantidad de pasos
y nuestros resultados son menos exactos que los conseguidos por una máquina

TIPOS DE DATOS ABSTRACTOS

Ejemplos de la vida cotidiana
Calcular la tela que debo comprar para hacer un mantel circular cuyo radio es de
65 cm
Algoritmo

Consola python

Ejecución

pi=3.1416

def area_radio(radio):

radio=65

area=math.pi*radio**2

area=pi*radio**2

print “area:”, area

print area

Me hizo falta vitropiso para terminar la planta baja de mi casa. El area de un
vitropiso es de 1052 cm2 debo sacar los centímetros por lada para saber cuántas
cajas comprar
Algoritmo
Proceso

Raíz

Escribir “escribe el numero”;
Leer x;
Si x >0 entonces
Escribir rc(x);
FinProceso

Consola python

Ejecución

Import math

import math

# raiz cuadrada

num=int(raw_input(“escribe el numero:”))

… math.sqrt(1052)

raiz=math.sqrt(num)
print raiz

Fui a la tienda a preguntar por mi cuenta y me dieron la siguiente lista: 54+82+75120+75-190
Algoritmo
Proceso
Cuenta
Suma <-0
Para x<-1 Hasta 6 Hacer
Escribir “dame un numero”;
Leer x;
Suma <- suma + x;
FinPara
Escribir “resultado”, suma;
FinProceso
Consola python
datos

Ejecución
print (“dame un numero”)
x=input()
suma=0
while x!=0:
suma =suma + x
print (“total {}”.format(suma))
print ((“dame otro numero”))
x=input()
print(“total”)


MCOM2_U1_A2_AURT.pdf - página 1/5


MCOM2_U1_A2_AURT.pdf - página 2/5


MCOM2_U1_A2_AURT.pdf - página 3/5

MCOM2_U1_A2_AURT.pdf - página 4/5
MCOM2_U1_A2_AURT.pdf - página 5/5


Descargar el documento (PDF)

MCOM2_U1_A2_AURT.pdf (PDF, 130 KB)





Documentos relacionados


Documento PDF mcom2 u1 a2 aurt
Documento PDF manual python
Documento PDF manual python
Documento PDF clase 2 lp
Documento PDF 00068240
Documento PDF actividades de aprendizaje en excel

Palabras claves relacionadas